[alsa-devel] [Alsa-user] Metallic recording in cs46xx on Thinkpad T22

Rene Herman rene.herman at keyaccess.nl
Wed Mar 12 18:17:43 CET 2008

On 12-03-08 17:59, Takashi Iwai wrote:

> At Wed, 12 Mar 2008 17:39:48 +0100,
> Rene Herman wrote:
>> On 12-03-08 15:43, Takashi Iwai wrote:
>>> At Tue, 11 Mar 2008 23:01:39 +0100,
>>> Rene Herman wrote:
>>>> On 11-03-08 08:24, Gadi Oron wrote:
>>>>> I am trying to record sound on an old Thinkpad T22 that uses the cs46xx 
>>>>> sound driver.
>>>>> Each time you start to record you have a 10% chance of having the 
>>>>> recording completely distorted and having a metallic sound. When you 
>>>>> look at the waveform it looks as though there are small segments with 
>>>>> sharp transitions between them, a little like if these segments were 
>>>>> moved a little from their correct place.
>>>> No insights, but I confirm the bug with a TerraTec DMX XFire 1024 (CS4624).
>>> Hm, cs46xx driver hasn't been much changes since long time ago (around
>>> year 2005).  The only big change was about some PM fixes, and I don't
>>> think it's relevant...  Could you run als-info.sh to get the status?
>> At:
>> http://pastebin.ca/939784
> The output seems truncated.  Could you give the generated file via
> "alsactl -f somefile store", just to be sure ?

Hmm, alsa-info.sh freshly downloaded from current hg. Anyways:

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: cs4624.state
Url: http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20080312/92e9e48a/attachment.bat 

More information about the Alsa-devel mailing list