[alsa-devel] [regression] 2.6.25-rc4 snd-es18xx broken on Alpha

Bob Tracy rct at frus.com
Tue Mar 11 21:34:21 CET 2008

Michael Cree wrote:
> Yes, the ESS1888 driver failed to work on Alpha about the 2.6.14 to  
> 2.6.16 kernel.   It came right with alsa release 1.0.13 (IIRC) and I  
> have been running the ESS1888 driver on an Alpha XP1000 without  
> problems for about a year.

Nod.  I take it things were working for you at least as recently as
2.6.22, then.  I can try that version and see if it works for me.  My
situation is that I can't swear I've tried anything involving ALSA on
the Alpha since 2.6.16 until recently, so I'm not sure this is really a
regression in my case.

Because I threatened to do it :-), I built a 2.6.25-rc4+iommu_patch
kernel with both the snd-es18xx and snd-sb8 modules available.  As
hoped (expected?), the snd-sb8 driver works fine.  This would imply
the problem is at least somewhat specific to the es18xx driver, and
that the underlying ALSA infrastructure is reasonably healthy (notice
that I intentionally avoided saying it was "sound" -- sorry, I never
could pass on low-hanging fruit).

Bob Tracy          |  "I was a beta tester for dirt.  They never did
rct at frus.com       |   get all the bugs out." - Steve McGrew on /.

More information about the Alsa-devel mailing list