[alsa-devel] PATCH - MIDI on ice1724 - real-time kernel problem SOLVED(?)

Martin Krüger m_a_krueger at gmx.de
Tue Jun 24 13:07:42 CEST 2008

Pavel Hofman schrieb:
> Pavel Hofman wrote:
> Ubuntu Studio 7.10 with kernel upgraded to 2.6.25 according to 
> Latest download of alsa from git, compiled by ./gitcompile.
> Ancient Duron 1GHz, Audiotrak Prodigy 192
> Both MIDI input (amidi -p hw:0 -d) and output (amidi -p hw:0 -S 
> F0411042110C000000000074FF0411042110C0000000000\
> 74F7F0411042110C000000000074F7F0411042110C0F0411\
> 042110C000000000074FF0411042110C000000000074F7F0\
> 411042110C000000000074F7F0411042110C0)
> work fine, no problems.
> Regards,
> Pavel.
> _______________________________________________
> Alsa-devel mailing list
> Alsa-devel at alsa-project.org
> http://mailman.alsa-project.org/mailman/listinfo/alsa-devel

Hi Pavel,

sorry for the long break, i was really busy at studying.

The problem still exists for me, and i tried to debug it a bit by adding 
printk's to the rawmidi module.
Unfortunatly, i am more confused at this problem than ever before.

I added printk("some text"); to the following subroutines:

- int snd_rawmidi_transmit
- snd_rawmidi_kernel_write1
- snd_rawmidi_kernel_write

As i read the source, these routines should be the ones who do all the 
midi output to the device. And the printk's should appear in the 
kern.log files.
Please tell me, if i am wrong here.
But none of the printk outputs appear in the logging. I added some 
outputs similar to the other ones to the Midi Input procedures, and 
everything works fine.

Does amidi write directly to the routines above? Or is there some Stuff 
between? I tried to read the amidi source, but my C/C++ knowledge is 
very poor, i am more on the java side of code...

Perhaps you have an idea where to start the debugging, to find that bug...

Thanks a lot,

More information about the Alsa-devel mailing list