[alsa-devel] snd-hda-intel[ALC883] scratching and stuttering sound on MCP78S board

Hans-Frieder Vogt hfvogt at gmx.net
Sun Jun 22 11:42:52 CEST 2008

I am experiencing severely scratching and stuttering sound on my nVidia MCP78S (GeForce 8200) based Asus M3N78-EMH HDMI mainboard, which has an ALC883 on board, running with an Athlon X2 4850e dual-core CPU.
It sounds, as if the sound buffers are not filled in time and are therefore repeated many times. The problem seems to be kernel / alsa-driver related, because I experience the problem also when running runlevel 1 with only a minimum processes.

Strange enough, the sound is OK when I do a larger compilation in parallel (kernel make with make -j 2), but the sound is not OK when I run burnK7 (two instances to load both CPU cores) => What is different in CPU loading or scheduling between these two load cases?

I tried several things so far:
Debian kernel image 2.6.25-2-amd64 (2.6.25-5)
self-compiled 2.6.25.x (with x in nothing to 5), with and without -rt patches
self-compiled 2.6.26-rc5, -rc6, -rc7
latest alsa-driver 1.0.17rc2

please find the alsa-info output here:

attached is my latest kernel setup (2.6.26-rc7, alsa driver modules now replaced by 1.0.17-rc2).

Please tell me your suggestions what the problem may be or how I could debug the problem.

Hans-Frieder Vogt                 e-mail: hfvogt <at> gmx .dot. net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: config.gz
Type: application/x-gzip
Size: 14872 bytes
Desc: not available
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20080622/8d7a5a71/attachment-0001.gz 

More information about the Alsa-devel mailing list