[alsa-devel] Problem with aloop

Benjamin van den Hout bvdhout at gmail.com
Sun Jun 1 18:15:35 CEST 2008

Hi Ahmet,

ive just read about aloop problems by chance, so excuse the late answer,
> for ive disabled recieving mails from this list. so also cc me when
> replying :)

No problem, I'm delighted somebody is answering my e-mails at all :)

> repeating stuttering
> try tickless kernel, as it improves the quality of timer interrupts
> dramatically.
> dont forget to enable high resolution timer support, hpet and so on.

OK, excellent tip. Thanks! High resolution timer support is already enabled
and I've got the kernel configured for "realtime" performance (CONFIG_HZ or
whatever it was called set to 1000 etc.). I'll try to see if the tickless
kernel makes any difference.

> > synchronization issue at the beginning
> this is still not resolved and its a pain in the ass to get this done
> right.
> ive implemented 4 different ways to solve it and im still not happy with
> what ive got.

The funny thing is, after I reverted to the 10.0.16 release tarball these
stuttering problems went away. So the fixes that were committed in
february/march under the 'fixes realtime behaviour' label actually made
things much worse..

> > kernel crash when closing
> do you really have to put at this manny places this del_timer?
> try to find the right place and resubmit. :)

I already presumed it was a bit much, I'll be the last one to deny that! ;-)

But then again, I'm not too familiar with ALSA kernel stuff anyway and the
existing documentation seems a bit sparse. Also, this patch was made as part
of a time-limited project at my company so I sadly couldn't spend more time
on it after I (crudely) fixed the bug. However, I'd love to refine my patch
(in my own spare time). Can you give me any pointers perhaps? They would be
greatly appreciated.

Thanks for taking the time to reply!

Kind regards,

More information about the Alsa-devel mailing list