[alsa-devel] [ALSA] hda-codec - Fix laptop models for Cxt5045

Takashi Iwai tiwai at suse.de
Tue Jul 1 11:54:32 CEST 2008

At Tue, 1 Jul 2008 09:07:30 +0200 (CEST),
Jaroslav Kysela wrote:
> On Mon, 30 Jun 2008, Mark T.B. Carroll wrote:
> > Greetings. I thought I should mention that your patch
> > http://kerneltrap.org/mailarchive/git-commits-head/2008/2/1/670694
> > broke headphone sound for me on a Toshiba Satellite P105-S6197,
> > sound card PCI ID 8086:27d8 with Conexant CX20549 codec. The speakers
> > silence when I plug the headphones in but no sound comes from them.

Do you mean that the no sound comes from the headphone even if you
plug it?  And, the speaker works again after unplugging the HP?

> > Details are at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=488063
> > but half of my Debian bug reports go ignored for years.
> > 
> > A sufficient workaround for me is to comment out the `default:' in the
> > `switch (board_config)' in the function `patch_cxt5045' in
> > sound/pci/hda/patch_conexant.c. Then everything works fine again.

Does the speaker auto-muting work if you do that?

> > The same problem appears to be reported by evilviper77 at
> > http://bbs.archlinux.org/viewtopic.php?pid=373770 - they have a
> > Toshiba P105-9339.

Please run alsa-info.sh (with --no-upload option) for both working
(patched) and non-working (the original) cases, and attach generated 
files to compare.  This will be helpful to analyze the problem.



More information about the Alsa-devel mailing list