[alsa-devel] 1.0.16rc2 -build issues

Alan Horstmann gineera at aspect135.co.uk
Wed Jan 30 22:03:45 CET 2008

On Wednesday 30 January 2008 13:03, you wrote:
> At Wed, 30 Jan 2008 12:41:46 +0000,
> Alan Horstmann wrote:
> > On Wednesday 30 January 2008 11:21, Takashi wrote:
> > >
> > > Could you apply the patch below and use ./hgcompile to configure?
> > >
> > > thanks,
> > >
> > > Takashi
> >
> > Patch applied OK.  Unfortunately, hgcompile complains that the Autoconf
> > version is too old on this system -needs >2.59 (looks like I have 1.4o).
> > What is the difference using that rather than straight configure?
> You need to regenerate the configure script itself.
> >  Is there a
> > way to work round it?
> Remove the line "AC_PREREQ(2.59)" in configure.in.

Thanks.  However, I could not get (the old) autoconf to produce a working configure script due to 'AS_HELP_STRING', so I added
to the patched adriver.h and used the original configure script, to proceed for now (which it did).

Unfortunately make didn't get much further, having more ??historic kernel?? trouble in memalloc:

memalloc.c: In function `snd_mem_proc_open':
memalloc.c:611: warning: implicit declaration of function `single_open'
memalloc.c: At top level:
memalloc.c:715: error: `single_release' undeclared here (not in a function)
memalloc.c:715: error: initializer element is not constant
memalloc.c:715: error: (near initialization for `snd_mem_proc_fops.release')
memalloc.c: In function `snd_mem_init':
memalloc.c:731: warning: assignment discards qualifiers from pointer target type

Sorry if this is causing a lot of extra trouble.

Regards  Alan

More information about the Alsa-devel mailing list