[alsa-devel] conversion of opti93x driver to use cs4231-lib

Rene Herman rene.herman at keyaccess.nl
Tue Jan 8 15:16:57 CET 2008

On 08-01-08 12:38, Takashi Iwai wrote:

Jaroslav -- do you know/remember why opti93x didn't use cs4231-lib?

> At Mon, 7 Jan 2008 20:08:01 +0100,
> Krzysztof Helt wrote:
>> Hi,
>> I posted some time ago two patches which converts opti93x driver to use cs4231-lib library. 
>> The opti93x chips are almost compatible with the cs4231 differing mostly by mixer.
>> This change greatly reduces the source of the opti drivers.
>> Here are patches:
>> [addition of opti93x details to the cs4231-lib]
>> http://mailman.alsa-project.org/pipermail/alsa-devel/2007-September/003395.html
>> and 
>> [conversion of opti93x driver to use cs4231-lib]
>> http://mailman.alsa-project.org/pipermail/alsa-devel/2007-September/003396.html
>> I will rediff the second patch as there were some changes to opti93x driver after sending the patch.
>> If it is not a good idea to do such conversion, please reply and drop patches.
> The only concern is whether this breaks the workign opti9xx stuff.
> If someone can confirm it's OK, then I'm 100% for these patches.
> Added Rene to Cc to hear his opinion.

Missed this one originally. I'll look into this in some detail but will need 
a few days. Obviously, if it works, it's desirable. Maybe Jaroslav knows why 
it's not that way now?


More information about the Alsa-devel mailing list