[alsa-devel] Problem with DELL XPS M1530

Anders Rønningen andersronningen at gmail.com
Tue Feb 19 19:25:24 CET 2008

Hi Takashi.

Some dmesg output:

[   14.192000] ALSA 
autoconfig: line_outs=1 (0xf/0x0/0x0/0x0/0x0)
[   14.192000] ALSA 
speaker_outs=1 (0xd/0x0/0x0/0x0/0x0)
[   14.192000] ALSA 
hp_outs=1 (0xa/0xf/0x0/0x0/0x0)
[   14.192000] ALSA 
mono: mono_out=0x0
[   14.192000] ALSA 
inputs: mic=0xe, fmic=0x0, line=0x0, fline=0x0, cd=0x0, aux=0x0
[   14.196000] ALSA 
dac_nids=2 (0x5/0x4/0x0/0x0/0x0)

Unmuted and adjusted Surround volume, but it made no difference.

- Anders

Takashi Iwai wrote:
> At Tue, 19 Feb 2008 17:24:04 +0100,
> Anders Rønningen wrote:
>> Hi. I am the mentioned user with this problem. Just thought I'd give you 
>> a little more info on this problem.
>> What wishie described was correct, except it's the internal speakers and 
>> the /left/ hp-jack that stopped working, while the right one is still 
>> ok. Like he wrote, the reason we started this debugging was to get mic 
>> sound on my system. The thing I think is worth mentioning is that with 
>> alsa 1.0.14 on an out-of-the box Ubuntu Gutsy, both hp-jacks and the 
>> internal speakers worked for me. People in #alsa told me that the module 
>> was not loaded correctly, but whatever was loaded _almost_ worked well :-)
> OK, please build the driver with --with-debug=full option and show the
> kernel messages such as "autoconfig: ..."  and "dac_nids...", etc.
> This contains the information that the pin configuration parser uses.
> Also, unmute and adjust "Surround" volume.
> Takashi

More information about the Alsa-devel mailing list