[alsa-devel] snd-hda-intel AD1981 - the microphone doesn't work

Takashi Iwai tiwai at suse.de
Tue Feb 19 15:44:43 CET 2008

At Tue, 19 Feb 2008 15:12:50 +0100,
Grzegorz Chwesewicz wrote:
> Thursday 14 of February 2008 13:14:18 Takashi Iwai napisał(a):
> > And, does a similar problem like Grzegorz's case occur on your laptop?
> > Some HP laptops (so far, AMD SB450-based) occasionally cause a hang-up
> > during recording from the mic when HD is accessed.  This is far more
> > nasty problem, and it's interesting to know whether this happens on
> > other chipset.
> 	Hi Takashi. I've experimented a little with power saving in HD Intel Audio. 
> I've noticed that using power saving with timeout set to 10 sec. solves my 
> problem partially. When arecord stops recording I can turn it off, wait 10 
> seconds, and recording works back again. This is obvious, because power 
> saving simply powers off and on device. I was wondering that maybe we can 
> implement ioctl or something that will dump "state" (informations that will 
> help in debuging) of device, when recording is not working, and "state" just 
> after power on to compare what causes breakage ? Can you give me some tips 
> about what informations are userful in debuging ?

Well, the question is what "state".  Interesting thing is that it's
specific to ATI SB, and seems irrelevant with codec chip.  So, the
codec information is likely useless.  But, I don't think the broken
situation is reflected on PCI reg space.

BTW, Andi Kleen also has a similar problem on his machine and he used
noirqdebug boot option.  But, in his case, the irq line of HD audio
device isn't shared with others.


More information about the Alsa-devel mailing list