[alsa-devel] Intel ICH7/Realtek ALC262 on MSI MS-7290 (Crystal 945)

Matthew R. Hurne matt.hurne at versatile.com
Mon Feb 4 23:16:42 CET 2008

Takashi Iwai wrote:
> At Mon, 04 Feb 2008 10:50:58 -0500,
> Matthew R. Hurne wrote:
>> Takashi Iwai wrote:
>>> At Thu, 31 Jan 2008 13:59:57 -0500,
>>> Matthew R. Hurne wrote:
>>>> Tobin Davis wrote:
>>>>> Sorry for not getting back sooner.   Could you try alsa-1.0.16rc2 with
>>>>> the following configuration:
>>>>>     ./configure --with-cards=hda-intel --with-debug=detect && make &&
>>>>>     sudo make install
>>>>> After it is installed, type "dmesg" and look for the alsa output
>>>>> (line-outs, speakers, etc).  Copy that into an email and send it to me,
>>>>> please.
>>>>> Tobin
>>>> No worries about not getting back sooner - I appreciate you getting back at all!
>>>> I've done as you requested, and here is the output of dmesg:
>>>> ALSA /root/alsa-driver-1.0.16rc2/alsa-kernel/pci/hda/hda_intel.c:1788: chipset global capabilities = 0x4401
>>>> ALSA /root/alsa-driver-1.0.16rc2/alsa-kernel/pci/hda/hda_intel.c:740: codec_mask = 0x1
>>>> hda_codec: Unknown model for ALC262, trying auto-probe from BIOS...
>>>> ALSA /root/alsa-driver-1.0.16rc2/pci/hda/hda_codec.c:2863: autoconfig: line_outs=1 (0x15/0x0/0x0/0x0/0x0)
>>>> ALSA /root/alsa-driver-1.0.16rc2/pci/hda/hda_codec.c:2867:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
>>>> ALSA /root/alsa-driver-1.0.16rc2/pci/hda/hda_codec.c:2871:    hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
>>>> ALSA /root/alsa-driver-1.0.16rc2/pci/hda/hda_codec.c:2872:    mono: mono_out=0x0
>>> As you see, there is no speaker output defined in the pin default
>>> config which is set by BIOS.
>>> If you don't get any sound with model=basic even after
>>> unmuting/adjusting Front, Headphone and Mono volumes/switches, then
>>> the problem is likely a missing EAPD via COEF comands...
>>> Takashi
>> I don't get any sound with model=basic either (nor with any other model listed for the ALC262).  Unfortunately, I have no idea what "a missing EAPD via COEF commands" means!  :-)  I know Tobin had replied offering to help out with this issue as well - perhaps he'll be able to do something with that?  I'll glady do anything asked of me (that isn't over my head), such as compiling from hg sources with debugging enabled and sending along output, etc.
> As a first step, upload the alsa-info.sh output with model=basic to
> double-check whether it's really done properly.
> You'll have some ideas about EAPD and COEF when you see
> patch_realtek.c.
> Takashi

Attaching alsa-info.txt generated from the latest alsa-info.sh in hg, run as:

./alsa-info.sh --no-upload

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: alsa-info.txt
Url: http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20080204/88562ec8/attachment-0001.txt 

More information about the Alsa-devel mailing list