[alsa-devel] HDA - AD1986a issues.

Tobin Davis tdavis at dsl-only.net
Fri Feb 1 23:57:35 CET 2008

On Fri, 2008-02-01 at 16:13 +0100, Takashi Iwai wrote:

> > Also, I had some very strange audio garbage with the tip on an HD
> Audio platform
> > that normally works ok.  I'm going to be tracking it down this
> morning, once I
> > get to work (1 hour).  I'm not sure if it is related to the AD1986a
> or the SCH
> > (gcap patch).
> AD1986A has a known problem when you assign the single stream to
> multiple DACs.  But, we should have fixed this already in 1.0.16rc2.

Ok, I can confirm on my test system that the HDA-GCAP and HDA-SCH
patches are ok.  I tested them on 1.0.15 with an AD1986a and they work
fine.  Same system with HG20080130 is aweful.  I'm trying to revert the
patch_analog patches one at a time to see which one is the problem.

> >  I do know that GCAP returns 2200 on this system, whereas a normal
> > ICH returns 4401.  The last bit may be significant (64bit vs 32bit
> stream).  I
> > need to reverify the SCH value, but this may be causing the issue.
> This is
> > critical for a launch coming up.
> Hm, this bit hasn't been tested.  OK, we need a fix for that.

No need to worry about this bit I guess.  It may only be relevant on a
system that runs 64bit OSes, and I'd assume that bit doesn't exist for
systems that can't.
Tobin Davis 

	"What do you do when your real life exceeds your wildest fantasies?"
	"You keep it to yourself."
		-- Broadcast News

More information about the Alsa-devel mailing list