[alsa-devel] patch 1/1: ASoC, DMA crash with application- resolved

Jarkko Nikula jhnikula at gmail.com
Mon Dec 22 08:17:57 CET 2008

On Sun, Dec 21, 2008 at 11:09 PM, Mark Brown <broonie at sirena.org.uk> wrote:

> On Sun, Dec 21, 2008 at 09:37:21PM +0530, naveenkrishna.ch wrote:
> >  To solve the DMA crashes i have sent a patch, it worked i dint found any
> > patches related to this issue,
> > I tried it on alsa kernel git...
> Please check with Jarkko's patch applied below - it's not in ALSA git so
> you'll need to cherry pick it over into Takashi's tree by hand:
Here's link to the patch and it applies into Takashi's tree:


And recent Oops fix (which is in Takashi's tree):


If these two don't help, then I think there must be either race somewhere or
bug in stopping of OMAP DMA. Anyway, it's a bug if DMA is still running when
executing omap_pcm_hw_free.

If possible, can you post a crash dump and/or use-case how to reproduce the
problem? I have TI Beagle board with OMAP3 and TWL4030 so I may be able to
reproduce it as well.


More information about the Alsa-devel mailing list