[alsa-devel] HDA: CLFE DAC on ALC889 (Acer Aspire 8930G)

Hector Martin hector at marcansoft.com
Wed Dec 3 01:59:14 CET 2008

I've been trying to get ALSA working with this laptop. So far the 
attached patch adds rear support to the existing 4930g model, and tries 
to add CLFE support. However, I haven't been able to get CLFE to work. I 
don't seem to get any audio through DACs/mixers other than the first two 
(front and rear).

I can assign the CLFE output (pin 0x16) to the front or rear DAC and 
hear the front audio through the CLFE speakers. I can also force the 
front DAC (0x02) or rear DAC (0x03) to use the CLFE stream and hear it 
through the front or rear speakers, so the audio is getting to the 
codec. But either DACs 0x04 and 0x05 aren't working, or their associated 
mixers (0x0e and 0x0f) aren't passing through the audio, or the OUT pins 
don't like selections above 1. I've checked that they're unmuted and 
that the volumes are turned up on both. I've also tried the 0x25->0x26 
DAC/mixer auxiliary pathway, which doesn't work either.

Here's what the relevant NIDs correspond to:
0x02 - (normally) Front DAC
0x03 - (normally) Rear DAC
0x04 - (normally) CLFE DAC
0x05 - (presumably) side DAC (no side speakers)

0x0c - (normally) Front mixer
0x0d - (normally) Rear mixer
0x0e - (normally) CLFE mixer
0x0f - (presumably) side mixer

0x14 - Front speakers pin
0x15 - Headphones pin (also EAPD for speaker amp)
0x16 - CLFE speakers pin
0x1b - Rear speakers pin

Here's what the codec graph looks like:

Any ideas? I'm pretty stumped here. Are there any other magic bits to 
enable the remaining DACs or mixers?

Hector Martin (hector at marcansoft.com)
Public Key: http://www.marcansoft.com/marcan.asc

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: 0001-Add-partial-8930G-support.patch
Url: http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20081203/41b5fdcc/attachment-0001.bat 

More information about the Alsa-devel mailing list