[alsa-devel] Asus M2NPV-VM (AD1986A) - Surround does work, snd-hda-intel dies on volume change

Ma Begaj derliebegott at gmail.com
Fri Sep 28 00:09:45 CEST 2007


Sorry if this email is not for devel mailing list, but this sounds to
me like a bug or development problem. If I am wrong, I will post it on
the user list.

And for the long email ... I just wanted to describe everything I tried.

I found a lot of messages about problems with sound chip AD1986A on
motherboard Asus M2NPV-VM. It is almost always the same problem,
surround does not work and sound mutes (module dies) when the user
change volume. That is my problem too.

I found a lot of solutions by using "model=3stack", sometimes with
"position_fix=1", but that does not work for all the users. I checked
the list, I read dozens of emails, but nothing helped.

I found a few patches on the list, but all of them were for kernels < 2.6.22.

I used Slackware 12.0 and model=3stack caused a terrible "weeping"
sound on the rear left speaker, but the stereo worked. I read a lot of
success stories with this motherboard and Ubuntu and after playing
whole week long on Slackware (kernel and, I decided
to try it with Ubuntu Feisty (2.6.20 and, although I did not
believe that Ubuntu should help. It actually helped partly because the
weeping sound disappeared, but I had only stereo.

When I changed the "Channel Mode" jack in alsamixer from 2ch to 6ch,
sound muted and module died. The only way to get the sound back was to
stop playing file, and rmmod/modprobe snd_hda_intel again.

Using model=6stack gives me surround sound by using "speaker-test -c6
..." (nice female voice guessed right every speaker)  but module was
still dying as soon as I changed volume.

Does someone have an idea what to do with this chip ... I am really
desperate and beginning to hate this great motherboard ...

Thanks a lot.


More information about the Alsa-devel mailing list