[alsa-devel] alsa timestamps

Jaroslav Kysela perex at perex.cz
Mon Nov 19 14:07:30 CET 2007

On Mon, 19 Nov 2007, Heikki Lindholm wrote:

> Heikki Lindholm kirjoitti:
> > Hello list,
> > 
> > I took up some old dusty code of mine that uses snd_pcm_state followed 
> > by snd_pcm_status_get_tstamp when in capture mode. The code used to 
> > work, but now the returned timestamps are all zeroes. Is there some API 
> > change done recently or is the whole timestamping deprecated or 
> > something? I've tried with different drivers on ubuntu's alsa .14 and 
> > gentoo's .14. I've also tried mmap'ed and r/w modes, and I'm setting the 
> > TSTAMP_MMAP sw param.
> I figured out that this doesn't happen when using hw:x,y devices. Is it 
> a documented feature that some (software?) devices don't fill in timestamps?

I think that it should be fixed. Could you send us 'snd_pcm_dump()' for a 
non-working device? It's probably ommited code in direct pcm plugins (dmix 
& etc.).


Jaroslav Kysela <perex at perex.cz>
Linux Kernel Sound Maintainer
ALSA Project

More information about the Alsa-devel mailing list