[alsa-devel] Alsa 1.0.13 (and others) does not work on ALC880

Takashi Iwai tiwai at suse.de
Sat May 19 17:11:49 CEST 2007

At Sat, 19 May 2007 02:08:14 -0500 (CDT),
Andrew Callan wrote:
> I have been without sound using Fedora Core ever since the 2.6.16 or
> 2.6.17 kernel update (2.6.16 crashed during initialization, so I could not
> tell whether sound worked or not).  It had worked well through the 2.6.15
> Fedora kernels.  I finally sat down tonight to work the problem as hard as
> I could and happened upon Eric and Tobin's timely exchange.
> First, simply adding probe_mask=1 to the snd-hda-intel options worked for
> me as well; I did not end up having to specify a specific model.
> Second, I too was seeing a LONG hang when trying to do:
> cat /proc/asound/card0/codec#0
> but now with the probe_mask=1, I do not see this.
> If it helps, the alsa-info.sh output for my system is at
> http://pastebin.ca/496293
> If it makes any difference, I'm not sure which model I had specified on
> the modprobe line at the time I captured this output.
> One thing I do notice is that after adding probe_mask=1, aplay -l does not
> show the Si3054 Modem which shows up in the alsa-info output.
> Thanks for the help you gave in the thread with Eric.
> Andrew

Interesting.  I've seen similar reports that probe_mask helps.
Do you disable the modem codec on BIOS or is it enabled?

If this happens even though it's enabled on BIOS, we'd need a
blacklist of non-working devices, or a more robust probing routine...


More information about the Alsa-devel mailing list