[alsa-devel] alsa-driver 1.0.14rc4 compile error resolved (was: Linux 2.6.21 regression with hda-intel (Conexant 5045))

Gunter Ohrner G.Ohrner at post.rwth-aachen.de
Fri May 18 11:35:39 CEST 2007

Takashi Iwai wrote:
>> > alsa-driver-1.0.14rc4.tar.bz2 release from alsa-project.org and use it.
>> This driver version does not seem to compile with Linux 2.6.21:

>> /usr/src/tmp/alsa-driver-1.0.14rc4/include/adriver.h:1168: error: too
>> many arguments to function 'pci_save_state'

> The configure script couldn't detect some conditions by some reasons
> on your system.

I found a reference to exactly the same problem here:


This thread mentions just this compile error and that it was supposed to be
fixed with 1.0.14rc4 but in fact wasn't.

My kernel was also built for the Core2 CPU, recompiling the whole kernel for
Pentium M helped and the compilation finished successfully.

There seems to be some macro magic going awry if Core2 is selected as the
target CPU.

I'll now test the freshly compiled driver and report if it works better than
the driver contained in vanilla Linux 2.6.21. :-)



More information about the Alsa-devel mailing list