[alsa-devel] ALSA driver for Native Instruments sound hardware

Takashi Iwai tiwai at suse.de
Mon Mar 26 19:27:53 CEST 2007

At Mon, 26 Mar 2007 19:21:21 +0200,
Rene Herman wrote:
> On 03/26/2007 07:14 PM, Takashi Iwai wrote:
> > Most likely we have to add some fix for building on the older
> > kernels, but I'll do it tomorrow...
> I've been wondering about that. Would it be good to say "version 1.0.15 
> will be the last version of alsa to support kernels < 2.6"? (1.0.15, or 
> 1.0.16, or ...). Older kernels are likely still used a lot in embedded 
> but do they need other sound hardware then what's already present in 
> alsa currently? If they do, would telling to them to "upgrade already" 
> be unacceptable? 2.6 is over 3 years old...

In alsa-driver tree, there is a flag (embedded in utils/mod-deps.c)
indicating 2.6-only drivers, so it's no big deal.   But the problem is
that there are too often API changes internally in 2.6 kernels, too.
Some are trivial to fix and some are not.


More information about the Alsa-devel mailing list