[alsa-devel] NVidia AC97 / CK804: arecord hangs in system call poll()

Takashi Iwai tiwai at suse.de
Sat Jun 30 01:09:21 CEST 2007

At Fri, 29 Jun 2007 13:36:15 +0200,
Rainer Menzner wrote:
> Hi,
> my soundcard is an onboard AC97 CK804 NVidia. I use snd-intel8x0 module. 
> Everything works fine except recording sound. When calling
>    arecord -f cd buffer.wav
> the program infinitely hangs, and an strace shows that it is a poll() 
> call that does not return. After interrupting, a wave file of 44 bytes 
> which is the header only is left. My setup is Kernel, all 
> ALSA-software is updated to the latest version, that is 1.0.14(a).
> In a previous setup with an older ALSA version and kernel 
> recording did work with the same hardware. Now that I updated all ALSA 
> software, even with that older kernel version the same recording problem 
> came up. From that I concluded that it is somehow related to the 
> ALSA-lib version. I have tried to downgrade ALSA-lib down to 1.0.0 to no 
> avail.
> I have also made tests appropriate if this would be an interrupt problem 
> (using pci=noroute et al) which also did not solve the problem.
> I have scrolled though the archives of alsa-user and there have been a 
> few posts regarding the same problem (but with other chip sets). 
> However, in those threads no definitive solution of the problem has been 
> discussed. So I tried it again in alsa-user but did not get any feedback ...
> Now, I finally try this developer list. Your comments and help are much 
> appreciated. Let me know if you need further info. I'm not a Linux 
> system programmer or specialist, but I would be willing to do some 
> debugging if somebody explains what to check.

Most likely a mixer configuration.  For example, it's now set up to
record from the SPDIF input or so.
You can check the detailed configuration from the generated file via
"alsactl -f somefile store".


More information about the Alsa-devel mailing list