[alsa-devel] [HDA Intel/STAC92xx] Alsa 1.0.14: error in stac92xx_auto_fill_dac_nid

Jan de Mooij jandemooij at gmail.com
Thu Jun 28 16:22:22 CEST 2007

I have a strange problem with alsa on Ubuntu Gutsy. If I compile and
install the Alsa 1.0.14 driver, my sound card is not detected, and
sound doesn't work. I also get the following message in dmesg:

[   33.360190] stac92xx_auto_fill_dac_nids: No available DAC for pin 0x15

So the problem seems to be in the stac92xx_auto_fill_dac_nids
function. When I copy that function from alsa 1.0.13 into the 1.0.14
source, everything works okay...

It looks like the function is rewritten for version 1.0.14, but for me
it does not work anymore. I have to do the above steps with each new
kernel update in Ubuntu Gutsy... Therefore I would like to fix it, but
I don't know where to start.

Thanks in advance.


More information about the Alsa-devel mailing list