[alsa-devel] [PATCH] snd-usb-caiaq: Fix compatibility with kernels < 2.6.19

Takashi Iwai tiwai at suse.de
Tue Jun 12 14:22:13 CEST 2007

At Mon, 11 Jun 2007 20:39:44 +0400,
Sergey Vlasov wrote:
> Kernels before 2.6.19 used a different signature for the urb->complete
> callback (an additional "struct pt_regs *regs" parameter was present),
> therefore snd-usb-caiaq needs some compatibility patches in
> alsa-driver, like snd-usb-audio.
> Signed-off-by: Sergey Vlasov <vsu at altlinux.ru>

Applied to HG tree.  Thanks.

I was too lazy to fix this since the function with less arguments
should basically work as it is -- but not confirmed actually :)


More information about the Alsa-devel mailing list