[alsa-devel] Gateway MP-6954 laptop, FC6, no sound

Bill McKie mckie at sky.arc.nasa.gov
Mon Jul 30 09:51:54 CEST 2007

I've been running FC6 on a Gateway MP-6954 laptop computer
since Oct-2006, and have been hoping that the regular FC6 yum
updates will eventually provide an alsa update that will support
the MP-6954's sound hardware.  So far, that hasn't happened,
and my system has never had sound capability.

Current system stuff:

uname -r

rpm -q -a | grep -i alsa

cat /etc/modprobe.conf
alias eth0 sky2
alias scsi_hostadapter ahci
remove snd-hda-intel { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
    /sbin/modprobe -r --ignore-remove snd-hda-intel
options snd cards_limit=8
alias snd-card-0 snd-hda-intel
options snd-hda-intel index=0
alias snd-card-7 snd-usb-audio
options snd-usb-audio index=7

alsamixer (v1.0.14rc1) reports:
 Card: HDA Intel
 Chip: SigmaTel ID 7634

Some Internet googling showed that Tobin Davis released
a source level Sigmatel STAC9250 (7634) test patch 6
(gateway-mp6954.patch.6) that appears to address this
problem back in December 2006.


Is this gateway-mp6954.patch.6 still appropriate to be 
used on my FC6 system? (My FC6 sys has all the current
yum updates applied.)

If this patch is appropriate, should I first remove the
existing alsa rpms before installing alsa from source
with the patch.  I.e. should I remove all 3 packages:


Will subsequent FC6 yum updates involving alsa then
disturb the patched alsa?

Thanks much,

More information about the Alsa-devel mailing list