[alsa-devel] No sound card found for ATI SB600 Azalia

Marek Zelem marek at terminus.sk
Mon Jul 23 23:00:17 CEST 2007


   I have Dell Latitude D531 notebook with
	00:14.2 Audio device: ATI Technologies Inc SB600 Azalia
sound card. Module snd_hda_intel is automaticaly loaded but no sound card
is detected. Here is the dmesg output:

ACPI: PCI Interrupt 0000:00:14.2[A] -> GSI 16 (level, low) -> IRQ 16
hda_intel: azx_get_response timeout, switching to polling mode...
hda_intel: azx_get_response timeout, switching to single_cmd mode...
hda_codec: No auto-config is available, default to model=ref
hda-intel: no codecs initialized
ACPI: PCI interrupt for device 0000:00:14.2 disabled

I have linux kernel Also tried alsa 1.0.14 kernel modules built
from alsa sources. The result was the same.

I have also tried all model=xxx arguments, nothing helped.

A also tried pci=noacpi but that caused boot failure.

Am I doing something wrong? Can you please help me with that?

Btw, the system is 64bit, could that be a problem?

lspci -nnv for sound card is:

00:14.2 Audio device [0403]: ATI Technologies Inc SB600 Azalia [1002:4383]
        Subsystem: Dell Unknown device [1028:0206]
        Flags: slow devsel, IRQ 16
        Memory at febfc000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2

  Thanks in advance


More information about the Alsa-devel mailing list