[alsa-devel] Intel hda ICH7 not worked anymore after using wine

Xavi de Blas xaviblas at gmail.com
Mon Jul 9 15:26:59 CEST 2007


2007/7/9, Takashi Iwai <tiwai at suse.de>:
> At Mon, 9 Jul 2007 14:16:43 +0200,
> Xavi de Blas wrote:
> >
> > Hello, I installed Wine on my Ubuntu Feisty on IBM-lenovo X60s, and
> > after reboot, sound never worked again.
> >
> > I tried to activate and to hide modem on the bios. I tried to stop
> > machine, take off battery, wait 10s, put battery again, and boot
> > without the power cable connected... and i tried lots of things from
> > ubuntuforums. I reinstalled feisty and sound doesn't work.
> >
> > I used alsa-info.sh script, here is the result:
> >
> > http://pastebin.ca/610317
> The codec isn't handled via the proper support code but only by the
> generic parser.  It won't work for Thinkpad.

I'm not sure if i understood... then, no solution for me now?

should i try the alsa svn code?

> > Should the new kernel 2.6.22 help me?
> X60 is known to work with recent kernels (but you'd better to give
> probe_mask=1 option to avoid the modem codec).

I tried, rebooted and pastebin changed:

This doesn't exist now:
# Codec: Conexant ID 2bfa
# Address: 1
# Vendor Id: 0x14f12bfa
# Subsystem Id: 0x17aa201b
# Revision Id: 0x90000

But still no sound.

I have this at the end of /etc/modprobe.d/alsa-base

options snd-hda-intel probe_mask=1 single_cmd=1 model=laptop-eapd

I have also a /etc/modprobe.d/snd-hda-intel.modprobe
with this:
options snd-hda-intel probe_mask=1 index=0 single_cmd=1 model=laptop-eapd

On dmesg there's this error two times (i suppose one for each one of
the files on modprobe.d):

$ dmesg | grep hda
[   24.932000] ALSA
hda_codec: invalid dep_range_val 53:1a
[  111.080000] ALSA
hda_codec: invalid dep_range_val 53:1a

Any idea? thanks

> Takashi

More information about the Alsa-devel mailing list