[alsa-devel] another device for opl3sa2

Takashi Iwai tiwai at suse.de
Thu Jul 5 16:38:57 CEST 2007

At Thu, 5 Jul 2007 01:03:02 -0700,
Paul Vojta wrote:
> On Wed, Jul 04, 2007 at 10:53:05AM +0200, Takashi Iwai wrote:
> > At Tue, 3 Jul 2007 19:24:23 -0700,
> > 
> > Hm, the silence appears to be an insufficient mixer initialization.
> > Touching mixer values doesn't help?
> Not sure what you mean by "touching mixer values".  I tried running
> alsamixer and immediately hitting Escape, but the bug still occurred.
> By the way, if I use the cs-4232 driver instead, then I don't experience
> the problem.  Of course, with cs-4232 the PNP is all wrong, so I used a
> non-pnp kernel with:
> modprobe snd-cs4232 \
>   port=0x534 cport=0x120 mpu_port=0x330 fm_port=0x388 sb_port=0x220 \
>   irq=5 dma1=0 dma2=1
> For comparison, the settings for opl3sa2 would be:
>   sb_port=0x220 wss_port=0x530 fm_port=0x388 midi_port=0x330 port=0x370 \
>   irq=5 dma1=0 dma2=1

A good finding.  So the possible causes are

- opl3sa specific initialization, such as snd_opl3sa2_detect()
- opl3sa specific mixer element, like Master Volume.

Can your machine suspend/resume?  It's interesting whether the sound
is resumed well with snd-opl3sa2 driver.  I remember it worked quite
ago, but not tested with the recent versions.


More information about the Alsa-devel mailing list