[alsa-devel] PS3 - Surround sound on SPDIF set-up

gt bradley gt.bradley at gmail.com
Tue Jul 3 04:17:35 CEST 2007

I've been beating my had against this for several weeks now.  (started
with fedora 6, tried adding in the plugings etc (version 1.0.12) -- also
tried upgrading to the current 1.0.14 version, without success (couldn't
produce surround-sound on teh spdif output).  I have now switched to
fedorea 7 and was able to have rythmbox play surround sound via spdif,
but have since lost that ability.  (but I'm convinced the hardware and
low-level drivers support it).  In order to limit the number of moving
parts, I have reduced to just trying to get speaker-test to play on all
6 speakers.

from pirut &
I have alsa-lib 1.0.14-0.4.rc3.fc7.ppc(64) and
alsa-utils 1.0.14-0.7.rc2.fc7.ppc

The default install has no asound.conf file.  (attempts to create a
"better" one didn't improve the situation).

I do not see a file matching the ps3 device in etc/alsa/cards nor
etc/alsa/pcm, but I have not found any documentation on adding entries
to the above directories.

[root at ps3 pcm0p]# cat /proc/asound/card0/pcm0p/info
card: 0
device: 0
subdevice: 0
stream: PLAYBACK
name: SPDIF
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 1
subdevices_avail: 1

[root at ps3 ~]# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PS3 [PS3], device 0: SPDIF [SPDIF]
 Subdevices: 1/1
 Subdevice #0: subdevice #0
[root at ps3 ~]# aplay -L
   Discard all samples (playback) or generate zero samples (capture)
[root at ps3 ~]# amixer
[root at ps3 ~]# amixer scontrols
[root at ps3 ~]# speaker-test -c 6

speaker-test 1.0.14rc2

Playback device is default
Stream parameters are 48000Hz, S16_BE, 6 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 4096 to 8192
Period size range from 256 to 256
Using max buffer size 8192
Periods = 4
was set period_size = 256
was set buffer_size = 8192
 0 - Front Left
 4 - Center
 1 - Front Right
 3 - Rear Right
 2 - Rear Left
 5 - LFE
Time per period = 17.821324

* above test only produces sound on channels 0 & 1.

xmms produces no sound and emits the following:
** WARNING **: alsa_setup_mixer(): Failed to find mixer element: PCM

Is it possible to get some help/pointers in the right direction?

More information about the Alsa-devel mailing list