[alsa-devel] azx driver compilation query

paul blakeley pblakeley at gmail.com
Fri Aug 31 14:43:50 CEST 2007

First of all thanks for replying.  Version 1.0.15rc1 successfully
compiled and I was able to insert the modules without any trouble.  I
noticed that the alsamixer didnt work for some reason, although I
navigated through the asound.state file.

Unfortunately with version of ALSA I am experiencing the same issues
as with the version 1.0.12rc2.  I think from memory this was when the
ALC888 chipset was properly introduced in ALSA.  Anyway the mixer
controls are very similar to previous versions and for the life of me
I cant figure out how these mixer controls map onto the chipset!  The
chipset block diagram can be found here:

Can someone help?

Also the other issues I having with this chipset is:

1. Line-in signal is distorted.
2. With a signal input and the 'front' mixer control set to zero you
can still here the signal output, although be it very low.
3. Capture mixer controls dont seem to do anything.
4. Line select between mic and line doesnt seem to do anything.

I would be extremely grateful if anybody could help with these.


On 8/31/07, Takashi Iwai <tiwai at suse.de> wrote:
> At Fri, 31 Aug 2007 11:41:34 +0100,
> paul blakeley wrote:
> >
> > Hi, I am trying to compile ALSA 1.0.14 and have compiled it but there
> > are problems.  How do you find out which ALSA driver is associated
> > with a chipset?  The chipset is ALC888, but when I run the ./configure
> > script what do I pass in to the '--with-cards' parameter?  I have
> > compiled with 'hda-intel' but I dont think this correct?
> It is correct.  ALC888 is a codec chip controlled by a HD-audio
> controller, which corresponds to snd-hda-intel driver.
> Anyway, try the new ALSA 1.0.15rc1 instead of 1.0.14, especially for
> HD-audio stuff.
> Takashi

More information about the Alsa-devel mailing list