[alsa-devel] Tascam US-428 USB Problems

Karsten Wiese fzu at wemgehoertderstaat.de
Thu Aug 16 11:54:48 CEST 2007

Am Donnerstag, 16. August 2007 schrieb Michael Bourgeous:
> I did some searching through source code, and found that the frame
> status of -70 (ECOMM) indicates an OHCI buffer overflow error.  As
> soon as the usx2y driver receives this it bails out of whatever it's
> doing, and jackd crashes.  I've tried changing the usx2y driver to
> ignore such errors, and while there are audio glitches when such an
> error occurs, jackd no longer crashes and the audio keeps playing.
> This leads to question one: Is there any reason to bail out instead of
> trying to recover from errors?

Audio glitches.
> I've tried all the different USB ports on my motherboard, different
> USB cables, and running through a hub instead of a direct connection.
> None of these things helped.  Though the usx2y message says "Most
> probably some hardware problem", I think this is something that is
> software related, as other USB devices have no problems.  So here is
> question two: what kinds of problems, software or hardware, would lead
> to a buffer overflow error, and can I fix this in the driver code?

The US-428 is the only device connected to that particular usb-port?

What are the other devices that work?
Do they also fully utilize usb 1.1 capacity?


More information about the Alsa-devel mailing list